Upgrade Guide

A guide to upgrading from v1 to v2 API

Introduction

Yapily's v2 API is now available, bringing with it an improved technical architecture, security and performance improvements and the following new features/implementations:

  • French Institutions
  • Data enrichment improvments, e.g. support for merchant categorisation and new upcoming profile enrichment.
  • IAM service to support Single Sign On across Yapily applications

1.0 to 2.0

To use version 2.0 of our API, please add the following HTTP header to all requests to Yapily:

x-yapily-api-version: 2.0-ALPHA

Changes

The following differences currently exists between version 1.0 and 2.0:

  • GET /consents & GET /consents/{consent-id}

    • The user's referenceId and timeToExpire are no longer returned in version 2.
  • Dashboard

    • The Dashboard does not currently support registrations for version 2 institutions. Temporary: this will soon be updated in version 2.0 to also show version 2 institutions. NOTE: In the meantime Institutions can be manually registered using our API.
    • Custom redirect uris are not currently supported for version 2 institutions. Temporary: this will soon be updated in version 2.0 to add support for custom redirect uris.

Support

If you have any questions about these upgrade steps, please reach out at support@yapily.com.